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Information and Notices

Copyright and Disclaimer

Copyright protection claimed includes all forms and matters of copyrightable material and 
information now allowed by statutory or judicial law or hereinafter granted, including without 
limitation, material generated from the software programs which are displayed on the screen 
such as icons, screen display looks etc.

Information in this manual and software are subject to change without notice and does not 
represent a commitment on the part of SAM. The software described in this manual is 
furnished under a license agreement and can not be reproduced or copied in any manner 
without prior agreement with SAM, or their authorized agents.

Reproduction or disassembly of embedded computer programs or algorithms prohibited.

No part of this publication can be transmitted or reproduced in any form or by any means, 
electronic or mechanical, including photocopy, recording or any information storage and 
retrieval system, without permission being granted, in writing, by the publishers or their 
authorized agents.

SAM operates a policy of continuous improvement and development. SAM reserves the right 
to make changes and improvements to any of the products described in this document 
without prior notice.

Contact Details

Customer Support

For details of our Regional Customer Support Offices please visit the SAM web site and 
navigate to Support/Contact Support.

www.s-a-m.com/support/contact-support/

Customers with a support contract should call their personalized number, which can be found 
in their contract, and be ready to provide their contract number and details.

https://s-a-m.com/support/contact-support/
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RollCall LogServer Introduction
1. Introduction
The RollCall LogServer collects logging information from units on a RollCall network, keeping 
a running log file of every event received. It maintains a current status file for every configured 
unit, which allows the LogViewer program to display the log information. Additional monitoring 
applications, such as the RollMap Schematic Viewer, can also access this log information

The LogServer connects to the RollCall network via IP. The LogServer has the ability to defer 
logs.The LogServer is configured using the LogServer Configurator.

2. Open the LogServer Configurator
When the LogServer is installed, a shortcut to the LogServer Configurator is created in the 
Windows program list on the Start menu and a LogServer icon ( ) is placed in the 
notification area of the Windows taskbar.

To open the Configurator, do one of the following:

• Click Start > All Programs > SAM > RollCall > LogServer Configuration.

• Double-click on the LogServer icon in the notification area.

The Configurator displays.

Figure 1 LogServer Configurator
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RollCall LogServer Open the LogServer Configurator
2.1 Configurator Menu Bar

2.1.1 File Menu

2.1.2 View Menu

2.1.3 Look & Feel Menu

2.1.4 Help Menu

2.2 Configurator Interface

The RollCall LogServer Configurator user interface is organized into tabs that group similar 
configuration options.

• The settings on the System tab configure the LogServer's Network Connection, and 
the LogServer Settings. For more information, See System on page 7.

• The settings on the Polling tab specify the general polling behavior of the LogServer 
and the units that will be polled for log information. For more information, See Polling 
on page 9.

• The settings on the Files tab specify the locations of the configuration files required 
by the LogServer. For more information, See Files on page 10.

• The settings on the Filters tab allow the LogServer to defer the processing of specific 
log messages. For more information, See Filters on page 13.

Start Service/Stop Service Toggles between starting and stopping the LogServer 
Service, depending on the current state.

Minimise to System Tray Hides the Configurator from view. The Configurator 
can be resumed by clicking on the LogServer icon in 
the notification area of the Windows taskbar.

Save Config Saves any changes made to the settings within the 
Configurator.

Exit Exits the LogServer Configurator.

Note: Exiting the Configurator does not stop the 
LogServer Service, if it is running.

Output Window Toggles the Output Window On and Off. The default is 
Off.

Note: The Output Window is only available on the 
System screen.

Dark Theme A light text on dark background color scheme.
Bright Theme A dark text on light background color scheme.

Note: Changing the color scheme displays a dialog prompting for the application to be restarted.

User Manual Opens a pdf file of the LogServer User manual.
About Displays information about LogServer.
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RollCall LogServer Starting and Stopping LogServer
3. Starting and Stopping LogServer
The LogServer Service runs as a Windows service. By default, it is configured to start 
automatically when the computer is started.

Right-click on the icon in the notification area of the Windows taskbar to display the following 
menu:

When the LogServer Configurator is running, the LogServer Service status is reported at the 
bottom of the screen, as either RUNNING or NOT RUNNING. This is updated every 30 
seconds; therefore, a delay of up to, but not more than, 30 seconds may occur before a status 
change displays.

Alternatively:

• Start, stop, or restart the LogServer from the Windows Computer Management 
(Services) screen, where it is listed as RollCall LogServer32.

Note: Configure the LogServer before starting the service for the first time. Once configured, the 
Configurator does not need to display for the LogServer Service to start.

Show LogServer Configurator Opens the LogServer Configurator
Hide LogServer Configurator Closes the LogServer Configurator
Exit LogServer Configurator Exits the LogServer Configurator
Start LogServer Service Starts the LogServer Service. The icon in the 

notification area displays with blue background .
Stop LogServer Service Stops the LogServer Service. The icon in the 

notification area displays with a red background .

Figure 2 Starting and Stopping LogServer
Issue 4 Rev 1 Page 6 © 2016 SAM



RollCall LogServer LogServer Configurator Tabs
4. LogServer Configurator Tabs

4.1 System

• Click the System tab to view and edit the Network Connection and LogServer 
Settings.

4.1.1 Network Connection

The Network Connection settings specify the RollCall network to which the LogServer is 
connected.

Figure 3 System Tab

IP Address The IP address of the RollCall Network

This address must present the RollCall Network over IP. This may be 
the address of a RollCall Proxy, an IP enabled Gateway, or a RollNet IP 
share.

Port Specifies the communication port through which communication to the 
RollCall network is made.

The default port is 2050.
Auto Reconnect In the event of failure, the network connection will be retried. The 

default setting for this feature is on.
Auto Reconnect 
Delay

The delay in milliseconds between each retry attempt. The range is 0 
to 15000 ms. Default value is 2000 ms.
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RollCall LogServer LogServer Configurator Tabs
4.1.2 LogServer Settings

The LogServer Settings specify:

• After entering the LogServer details, click Save Config. The LogServer is stopped 
and restarted when these changes are applied.

4.1.3 Distributed Logging

This feature allows multiple RollCall Log Servers for redundancy.

4.1.4 Output Window

The lower portion of the LogServer Configurator window displays informational messages 
pertaining to the operation of the LogServer.

To toggle the Output window on and off:

• Click on the View menu, and click on Output window.

LogServer Name The name of the LogServer, as it is displayed by RollMap, RollView, 
or the RollCall Control Panel.

By default this is LogServer, but it can be changed to more easily 
identify the LogServer. For example, in an installation where more 
than one LogServer exists.

Primary Port The primary server IP port is bi-directional. All log data received by 
the server is sent to all clients on this port, and the clients can also 
write log data back to the server. This port is used by RollMap and 
other vendor applications to monitor events within the RollCall 
network.

Secondary Port The secondary (write-only) IP port is used by applications that need to 
write new log data to the server, but have no need to receive changes 
or any other log data from the server. The port is used by RollSNMP 
and any other devices to write data to the log server.

Socket Timeout (in 
seconds)

Defines a timeout period, in seconds. Both Primary and Secondary 
ports will close when they have been idle for the duration set for the 
timeout.

Setting the timeout to 0 (zero) will set the ports so that they do not 
timeout.

Enable 
Distributed 
Logging

As the tick box suggests, this enables the Distributed Logging feature.

Domain This sets the Domain value, the range is from 1 - 232 and is set to 
default at “110”.

Unit Address This parameter allows the user to set the Unit Address, because each 
log server must have different Unit Addresses. Default is “00”

Redundant Peers This allows the user to input the IP address for each Log Server.

Note: This window displays only if enabled from the View menu.
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RollCall LogServer LogServer Configurator Tabs
4.2 Polling

• Click the Polling tab to access the LogServer Polling settings.

4.2.1 Polling settings

The Polling settings section on the Polling tab specifies the general polling behavior of the 
LogServer.

To configure the Polling settings, specify the following information:

Figure 4 Polling Tab

Unit Poll Rate The minimum time interval, in seconds, at which the specified units 
are polled for log information. The default is every 10 seconds.

Max Missed Polls The number of failed polls, at the specified unit poll rate, that must 
occur before a unit is declared lost. The default is one failed poll.

The time taken for the LogServer to declare a unit lost is equal to the 
maximum number of missed polls, plus one, multiplied by the unit poll 
rate.

Automate 
population of 
Polling List

Select this option to automatically populate the polling list from the 
available units on the specified RollCall network. By default, this 
option is disabled.

Note: Units added to the polling list by this option are not visible in the 
list until the pollinglist.xml is reloaded. 
Issue 4 Rev 1 Page 9 © 2016 SAM



RollCall LogServer LogServer Configurator Tabs
4.2.2 Network and Polling List

The Network section on the Polling tab displays the current RollCall network, and the Polling 
List contains a list of the units that are monitored by the LogServer. The LogServer can be 
configured to poll several units, and the LogViewer and RollMap applications can be 
configured to view the whole list or subsets of it.

The Network list is automatically updated to display the units currently on the RollCall network 
(for example, as units are added or removed from the network). However, if the network is not 
available when the LogServer is started, the Network list is not updated until the Re-connect 
button is clicked, or if the network connection is set to Auto Reconnect.

To add a unit to the polling list, do one of the following:

• From the network list on the left, drag and drop a unit into the Polling List on the right.

• Click Add All, to automatically add all suitable units found in the Network list to the 
Polling list. Units are defined as ending in:00.

• Click Add and then type a unit address in the RC Address field.

To remove a unit from the polling list:

• Click on the unit name in the list, then click Remove.

Select multiple units by using Shift + click or Ctrl + click.

• After populating the polling list, click Save Config. The LogServer is stopped and 
restarted when these changes are applied.

4.3 Files

• Click on the File tab for information about the LogServer configuration files, Current 
Status file, and the Running Log file.

Figure 5 Files Tab
Issue 4 Rev 1 Page 10 © 2016 SAM



RollCall LogServer LogServer Configurator Tabs
1. To reset all file locations to the default values, click Reset Defaults.

2. After completing changes to the file locations, click Save Config. The LogServer is 
stopped and restarted when these changes are applied.

4.3.1 Log Filters

The log filters file contains information about the log deferral settings, which are specified on 
the Filters tab.

The default name of the log filters file is filterrules.xml, which is located in the 
LogServer installation directory. 

• Click Change location to specify a different path to the log filters configuration file.

• Click Reload to load a new log filters configuration file, or to reload the existing one if 
it has been changed outside of the Configurator.

4.3.2 RollCall Units

The idnames.ini file contains the unit type values that are used in the Unit Type field on 
the Filters tab. The default location of this file is the LogServer installation directory. The 
current location of the file is displayed in the text field.

• Click Change location to specify a different path to the RollCall Units configuration 
file.

4.3.3 Masking

The sysmasks.txt file is the centralized mask file used by the LogServer. Log client 
programs such as RollMap V3 support this feature. The default location of this file is the 
LogServer installation directory. The current location of the file displays in the text field.

• Click Change location to specify a different path to the Masking configuration file.

4.3.4 Polling List

The pollinglist.xml file contains the units that have been added to the LogServer's 
polling list. The default location of this file is the LogServer installation directory. The current 
location of the file displays in the text field.

• Click Change location to specify a different path to the Polling List configuration file.

• Click Reload to reload the pollinglist.xml file. Note that if the Automate 
population of Polling List option has been selected on the Polling tab, any units that 
have been added automatically are not visible in the Polling list until the 
pollinglist.xml file is reloaded.

4.3.5 Current Status File

The current status file lists all units and modules and their current logging fields.

The default name of the current status file is curstat.txt, which is located in the 
LogServer installation directory. To allow viewing by multiple networked PCs the file should 
be located in a directory visible to all.

The current path to the current status file displays in the text field.

• Click Change location to specify a different path to the current status file.

If current status file updates are enabled, specify the interval, in seconds, at which 
they will occur. If 0 (zero) is entered, no Current Status file is generated. The default 
interval is 60 seconds.
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RollCall LogServer LogServer Configurator Tabs
• To clear the contents of the current status file, click Delete Curstat and then click Yes 
in the dialog box that displays.

This is useful if modules are permanently removed from the network.

4.3.6 Running Log

The running log file contains a history of all log messages that the LogServer receives and 
generates. When enabled, all messages are appended to this file. By default, this file is 
named logoutput.log. The default location of this file is …\<installation directory>\log. The 
current location of the file is displayed in the text field.

• Click Change location to specify a different path to the running log file.

The Roll-over frequency specifies how often a new running log file will be created.

4.3.7 LogServer Configuration File

The logserver32conf.xml file is the LogServer's main configuration file. It holds the 
configuration options that determine how the LogServer functions.

It is located in the LogServer installation directory and must not be moved.

4.3.8 LogServer Debug File

The ls32debug.txt file contains information that can be used by SAM support to determine 
the source of LogServer problems.

It is located in the LogServer installation directory and must not be moved.

NONE The running log file is not rolled-over at any specific time interval. When the 
file size reaches 5MB, the existing file is renamed. The following example 
illustrates how the running log files are renamed, where the name of the 
running log file is logoutput.log.

When logoutput.log reaches 5MB. It is renamed logoutput.log1 
and a new logoutput.log file is created.

When the new logoutput.log file reaches 5MB, it is renamed 
logoutput.log1 and the existing logoutput.log1 file is renamed 
logoutput.log2.

This pattern continues until the following files exist:

logoutput.log
logoutput.log1
logoutput.log2
logoutput.log3
logoutput.log4
logoutput.log5

At this point, when the logoutput.log file reaches 5MB, 
logoutput.log5 is deleted, a new logoutput.log is created, and all of 
the other files numbers increment by one.

WEEKLY
MONTHLY
DAILY
HOURLY
MINUTELY

The running log file is rolled-over at the specified time interval and the old 
file is renamed with a timestamp. 
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RollCall LogServer LogServer Configurator Tabs
4.4 Filters

• Click on the Filters tab for the settings to allow the LogServer to defer the processing 
of specific log messages.

This can be useful if a log field from a unit is rapidly cycling between two values. By deferring 
the log, it will remain constant until the value stabilizes.

For example, if a unit is cycling once every two seconds between INPUT=OK and 
INPUT=LOST. If INPUT=OK is deferred for five seconds, the unit will show as INPUT=LOST 
until INPUT=OK for five seconds without change.

• To set a log deferral, click Add and then specify the following information:

• To remove a deferral rule, select it in the Summary list, and then click Remove.

• After completing the changes, click Save Config. The LogServer is stopped and 
restarted when these changes are applied.

Figure 6 Filters Tab

Log Field Header The log key to match against. (In the example, INPUT).
Log Field Value 
(optional)

A specific log value to match against.

Unit Type 
(optional)

The type of unit for which to apply the deferral. If no value is specified, 
the deferral is applied to all units.

Deferral time The time, in seconds, to defer the log.
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RollCall LogServer Troubleshooting
5. Troubleshooting

5.1 Older Versions of the LogServer

Before attempting to run the LogServer, ensure that no previous versions of the LogServer 
are running.

It is recommended that all previous LogServer installations are uninstalled.

5.2 TCP Ports

Before running the LogServer, it is recommended that you verify that TCP ports 2052 and 
2056 are not assigned to any other applications.

To check TCP port usage:

1. Open a command prompt window.

2. At the command prompt, type:
netstat -a

This displays all current connections and listening ports.

Alternatively, the netstat -b command, which lists all of the executables using each 
listening port can be used.

If one of the ports required by the LogServer is already assigned, the LogServer will stop.

5.3 Incorrect Operation

If the RollMap or LogViewer applications do not show all logs, ensure that all units connected 
to the LogServer use the same LogServer name throughout and that there is not another PC 
also operating a LogServer.
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